UV design bigger than texture make it stretched

Hi,
I’ll make a silmple example. When my UV exceeds the border of a texture the exceeded part in blender looks good (texture is repeated), but in Unity its stretched. Is there a way to make it look in Unity like in Blender without making bigger texture files?

Image to make it clear:
alt text

Select the texture in the project view. Look at the import setting in the inspector and make sure the wrap mode is set to repeat and not clamp.