UWP Build and Debug on Windows 11 ARM64 in Parallels M1 Mac

I am not sure this is supported, but thought I would ask anyway.

I have been developing on a Windows 10 computer. I am using 2020.3.26f Unity. I have Visual Studio 2022 as the build environment.

I have set things up so that Unity builds out a visual studio solution targeting UWP. When I go to build and debug it, I can this error:

Unable to start program
'C:......\GameAssembly.dll'.

C:.....\GameAssembly.dll is not a valid win32 application.

I have tried building as x64 as a target and ARM64 as a target. Either one gives the same error.

Is there some way to set this up so that it will run and allow me to debug in Visual Studio in this configuration?

Can you show a screenshot of what you’re seeing? Could it be that Visual Studio is trying to launch “Il2CppOutputProject” instead of your actual game project?

In solution explorer, try right clicking on the project that’s named after your game and selecting “Set as Startup project”. Does that make any difference?

I feel really stupid.

You know how when you are trying something that you think probably will not work, then when it doesn't rather than looking at obvious things you just assume that it isn't working because it isn't supported or needs some special config?

That is what happened here. I totally should have seen that I wasn't running the main project. That and I didn't realize there were to projects that could be executed.

Thanks you!!!!

It works fine.

Out of curiosity, are you able to run it natively as ARM64? Or does only x64 work?

I can build and run for x86 on the local “machine” (the VM). If I choose ARM64 the only option is to deploy to a “Device”. When I try to debug it says it can’t connect to a device at 127.0.0.1. I supposed there might be a way to configure the local machine to debug, but I have not bothered because x86 works for me.

It does not allow me to debug x64. I get errors about the deployment target “Local Machine” does not support projects targeting x64.

I assume all of this is all due to the ARM64 Windows 11 I am running only supports emulation of x86.

I met the exactly same problem and you saved my life! Thanks!