V 4.5.0f6 Android Lightmapping is displaying Bright white without any lights in the scene.

I’m using Unity Android pro.
No post processing effects are on.

Basically my scene light maps fine when building for windows pc, but displays bright white when switching over to Android.

The light map itself looks fine in the inspector, but is displayed extremely bright and over saturated within the scene/game.

Lightmapping Settings:

  • Mode: Single Lightmaps
  • Quality: Low
  • Bounces: 0
  • Ambient Occlusion: 0.3
  • Max Distance: 0.1
  • Contrast: 0.5
  • LOD Surface Dis: 1
  • Lock Atlas: false
  • Resolution: 50
  • Padding: 0


Go to build setting > PC and go Player setting and disable use Directx 11. It works for me.

Thanks! that worked for me (build setting > PC and go Player setting and disable use Directx 11.)

the problem is with dx11… switching between PCs gives me different exposures on lightmapping… on my old netbook it looks the same as the android builds, but on my new notebook every lightmapped surface looks overexposed…

seems like a bug… unity devs should work on this…

Same issue here. I just went from version 4.3 to 4.6. When I loaded everything from before everything looked way over bright when creating light maps. I adjusted the values down so get them to look right, but when I compiled a test to mobile, it was very dark.

So if you are having a similar issue, the above fix worked great!