very bad quality

So i made this gun in blender but when i exported it to unity it got pixelated and very bad quality. I have tried changing some import settings but nothing works. I would very much appreciate all help i could get.

Go to the material of your model and select it, you’ll see on the inspector panel the compression options, select the target for your game and the max-size of your texture, if it isn’t enabled select override for… to activate it 102889-map.png

The issue is probably the shader settings. Try adjusting the shaders. I don’t know the kind of texture you’ve got but just play around with the shader settings.