Very weird dark level loading?

I have a very weird problem. Whenever I finish the first level and my game auto loads to second level , the 2nd level becomes dark. I am sure there is nothing wrong with lights as everything is in default and everything is the way it should be ? What could be the problem ?
Without auto loading and when I go to my 2nd level’s scene and play it is well lit. Only when auto loading its dim and not well lit.

Any help is appreciated. Thanks

I had the same problem,
It seems to be a problem with the “continuous baking”.

to fix it:
Lighting/Scene/other settings/ untick “continuous baking”/ hit “build”

you’ll need to do this for every level.
good luck,

For those in the most recent version of Unity as of this date:

You have to go to Window → Lighting. In that Window, look for the “Debug Settings”. Untick the “Auto Generate” checkbox and hit the “Generate Lighting” button beside it. That should take care of it in the editor.

All you have to do is uncheck auto at the bottom.
Thanks @tomhughes

I have same issue, I fix the issue using this article.

Have a nice day.

Here’s an update for what worked for me with Unity 2021.3.12f1.

The previous answers in this thread helped me get to these solutions, so kudos to everyone who wrote answers before me!

Two Methods to avoid scene darkening.

  1. Match lighting in your scenes.

  2. In Lighting Settings, Click “Generate Lighting” for all your affected scenes.

1) Match lighting in your scenes.

When the lighting was different from one scene to the next, the first scene was always properly lit, but the second was darkened. When I loaded multiple scenes in a sequence, all the scenes that had the exact same lighting setup were all lit as designed, but any scene that had any deviation from the original was darkened. I got rid of the darkening by just having all the lighting in my scenes be *exactly* the same.

2) In Lighting Settings, Click “Generate Lighting” for all your affected scenes.

I added a start screen and end screen, on 2D canvases, and that messed up the lighting consistency across scenes. The following resolved that.

a. Open Lighting Settings: Window > Rendering > Lighting

b. Click “Generate Lighting” at the bottom of that window (any tab). Do this for ALL your scenes that have 3D lighting. I didn’t do it for my 2D start & end screens, as they didn’t have “lighting”. (I did try adding the same lighting to those 2D screens, but that didn’t stop the darkening from happening.)

c. For each scene that you “Generate Lighting” for, a new folder will be created (inside your scenes folder) containing LightingData and ReflectionProbe files.

d. Now that each scene has its own lighting data, Unity won’t try to recreate it for each scene, and everything should be lit as designed.

e. If you want to remove the generated lighting for a particular scene, just delete the created folder associated with that scene. If you change the lighting in a scene, just press Generate Lighting for that scene again, and it will overwrite the old lighting data for it.

I hope these approaches can help some people. :slight_smile: