VFX Graph particles flickering in Alpha Blend Mode

Hi !
Does anyone know how to fix this ?
Basically, the particles of the VFX Graph work just as expected until using the Alpha Blend Mode in the Output Particle Quad. That’s when the particles start flickering like in this video.
It is working just fine when using Opaque or Additive Blend Mode.

I tried removing each and every other blocks but it’s still flickering. Removing the Set Angle block reduced most of the flickering (only a few particles still flickering), but it’s still quite noticeable.

Also, I tried reinstalling HDRP, and I am using Unity 2019.3.13f1 (which I updated a few weeks ago).

I also get these errors, I don’t know if it’s related :

Could not extract GUID in text file Assets/VFXDefaultResources.asset at line 17.

Could not extract GUID in text file Assets/VFXDefaultResources.asset at line 19.

Broken text PPtr. GUID 00000000000000000000000000000000 fileID 11700000 is invalid!

Thank you for your help :slight_smile: !

VFXGraph Flickering - YouTube!

Click on your output particle node then go to the inspector look for sort under particle options and turn it off.

particles rendered additively, look pretty much the same regardless of the order you draw them in, as 2 particles would both add color to existing screen color, ending up with the same end result, However with blended mode the end result is different depending on rendering order. So you have to make sure that the particles are either separated enough in Z-space that they won’t keep swapping z position, or that the particles are sorted ( adding performance overhead for sorting )
Check here for detail on changing shader graph sorting. https://forum.unity.com/threads/shader-graph-shaders-and-particle-sorting-fudge.746822/

For regular particle system there are also options for particle sorting on the Renderer.
But just be aware of extra performance cost.
Note:… the sorting is within that particle-system, and it won’t sort between different particle systems.
So if you have 2 different particle systems at roughly the same Z position you might get whole particle systems flickering behind each other… keep them separate in Z. use the sorting fudge or layering to draw certain particle systems later.

Thank you for your answer @JonPQ!
I don’t think there is a way to use a shader on a VFX Graph particle, is there ?
I’ll try to find a way to seperate them.

A page is open for voting on unity issue tracking if you want this bug fix : Unity Issue Tracker - [GPU Sorting] Outputs flicker when setting Alive selectively and sorting is on.