Video assets won't import...mostly.

I’m putting in some pre-rendered cutscenes for my game, and for a few weeks I’ve been using a placeholder cutscene. Back (a Unity version or two ago) when I imported the placeholder, everything worked as expected.
Now that I’m ready to put in the actual cutscenes, they will not import correctly. They show up in the project asset browser, and there’s a Unity metadata file, but it’s like it doesn’t recognize that it’s a video, and has no import settings and won’t make a movie texture out of it. I’ve attached a picture so that you can see what I’m talking about.
Solutions I’ve tried:

  • Reinstall Quicktime
  • Render video in various formats (including .avi, .mov, .m4a, etc)
  • Run Unity as Administrator

Picture: My project assets browser with the “Cutscene Placeholder” imported correctly (from a while ago) and one of the final cutscenes called “SVVM_EndingCutscene1_v2” which does not show up as a movie texture.

Assets put in the streaming assets folder won’t be converted to ogv. I would guess your placeholders were in a different folder and were getting converted to ogv by unity.

You’ll want to convert them externally if you want to place them in streaming assets.