Video Color Profile bug

I have imported a video of a 3d animation into Unity. The video looks great when played in Quicktime but when I run the video in the editor the colors don’t match. I have the quality at 100% and have enable bypass sRGB sampling. Is there anything else I can do to get the color profile of unity to match the video? Or is there a better color profile or codec I need to use to ensure the video makes the source in Unity.

The video was exported as a .mov file from an image sequence in Quicktime Pro using an H.264 codec at maximum bit depth and render quality.

Hi guys,

sRGB and quality is not your solution i think, I have this idea.

Your problem is like you print image on color paper, the color of the image that comes out from the printer will not match with the real color that you want to print. From my experience we must use white paper to make our picture come out with the correct color.

The main idea is make your plane (that has video material) to be “LIKE” multiply layer to the white space.

First step is set the material of your plane be more metallic, and smoothness around 0.5 (you can play with this) thick the reflection on forward rendering options, next step is make our mirror (plane) reflecting white color.

Go to window > lighting and set your Skybox material using Sprites-Default, it will make you entire world become white.

It will help your video color more bright (increase saturation), I’ve tested it. Good luck :smiley:

sorry for my English :frowning: