Video in fully immersive mode

When trying to play video using Video Player component in fully immersive mode I get the following error:

Operation GetVideoTrack not currently supported in visionOS.

Is the Video Player component not yet supported in visionOS? And if not, is there an ETA for when it will be supported?

1 Like

It is not supported at the moment. We are working on support for it and expect it to land fairly soon, but we don’t have an ETA.


Just wanted to check up on this here in this thread since I got a PM that this was working now. I still cannot get it to work, so I assume it is still not supported?

Yeah, I think we’re still waiting for some changes to core Unity. I tried it as well (with 2022.3.16f1), and videos are still failing to load on the simulator.

1 Like

Hey there! Hey there! I’m happy to report that a fix for VideoPlayer landed in 2022.3.18f1.

I just did a test using VideoPlayer in builds with both VR and Windowed mode configurations. I attached a VideoPlayer component to a quad (GameObject > 3D Objects > Quad) and set it to loop with a VideoClip asset crated from a .mov file. As expected, I saw the video play. Can you try updating to 2022.3.18f1 and see if that fixes the issue for you? If you are still having trouble, please submit a bug report with a project that replicates the issue.

Thanks, and good luck!


Similarly, using a VideoPlayer in MR mode with Render Mode: Render Texture should now work, with the caveat that you must use PolySpatialObjectUtils.MarkDirty to flag the RenderTexture as dirty every frame.


I can confirm that VideoPlayer works. :+1:

1 Like

Hi, guys trying to play video in Mixed Reality space but it’s not working with the quad and with render texture as well, using lates 1.0.3 Polyspatial version, Unity 2022.3.18f1, and XCode 15.2 in Simulator

Are you using PolySpatialObjectUtils.MarkDirty every frame that the video is playing in order to signal that it should be transferred via PolySpatial? If so, it may be a texture format issue or something else. If you can submit a bug report with a repro project and let us know the incident number (IN-#####), we can investigate.

Is streaming from a URL supported? I am able to play a video from a local url but not from the server.

Is this in VR (immersive) or MR (bounded/unbounded) mode? If it’s MR, are you using VideoPlayer or the VisionOS Video Component?

MR using VideoPlayer.

1 Like

I was able to get it to work; however, the default security policy requires that the URL be HTTPS. I used to test in the simulator. It should be possible to modify the security policy to allow HTTP URLs, but I’m not sure of the exact steps for a Unity visionOS project.