Video Player & GearVR?

Hello All!
We are creating an app, where utilizing the video player is imperative. It is all working perfectly in the editor, but when we deploy to GearVR, the videos don’t play at all. When we switch to a URL (video hosted on AWS), it takes 20-30 seconds to start playing. The video on AWS is only 33MB. The 360 video we are trying to play is ~800MB, but won’t play at all. I waited 2-3 min to see if it would show up, and also set the video to Preload. Didn’t work. Is this an inherent problem with the new video player? Anyone had this issue before? Thanks for the help.

I’m having a similar problem.
When I preload the videos in the proyect it works fine in the editor and in the GearVR (some video weren´t working in the GearVR but I fixed it by checking the Transcode option in them) but when I try with a URL It just keeps giving an error.

Hi again!
I tried the AWS and got it working so thanks!
Just writing again to let you know I got differences from 5 seconds to two minutes on loading the video depending on the network I was connected to.