viewport ceased to work shortly after first-time running of Unity, hasn't returned

Hey guys.

So basically I ran Unity for the first time today, and initially I was able to view the first island demo scene in the view port. However shortly after trying to navigate the environment a little bit, it ceased to display at all. I can see a little error/assert at the bottom left.

Expanding gave me the following read out, which I'll attach here. Among the several asserts that I can read out of the console, the one that repeats is this:

!IsNormalized(dir) UnityEngine.Camera:ScreenPointToRay(Vector3)

I'm very new to Unity and just curious if anyone knows what would cause this. I've updated my video drivers and DirectX, and tried restarting/reinstalling, without much luck.

Any help would be appreciated.


I can't confirm it myself, but this error is apparently fixable by going to Window > Layouts > Revert Factory Settings...


If none of the other answers fix it, click any object in the scene hierachy, move your mouse over the scene view and click F

It sometimes happens when you zoom out way too far