Virtual reality supported keeps disabling - Vive

I have a project that I didn’t check for a couple of weeks, and suddenly my VR has stopped working. I can use SteamVR Home and other apps just fine. I opened the project, and it cleared my inspector settings, so I had to drag them back, as well as my VR support settings. I try re-enabling it, but it doesn’t do anything when I press play, and then disables itself again once I got off play mode.

I’ve tried adding “OpenVR” and “None” as some have suggested, but get the same result. I’ve tried it on a brand new project, and updating Unity to 2018.1.6f1. I was on a version of 2017.2 prior. I get the same issue all around.

I’m at my wit’s end! It’s very urgent, as I have a deadline coming up, and can’t get it working!

EDIT: Uninstalling SteamVR, and reinstalling gets it to work on a brand new project, but not my old one.

Seems to have been a mismatch with SteamVR and Unity. After I reinstalled SteamVR, I deleted the old CameraRig prefab in my project and replaced it with their newer one. This fixed it. It doesn’t disable each time I stop gameplay, as well.

It was a very annoying, random issue that seems to not be mentioned anywhere else. Hope it can help someone else!