visionOS Release Notes Beta 0.4.3

We have published a new release (0.4.3) with the following updates:

  • Added documentation for Volume Camera about configuration assets.
  • Fixed build error if trying to build for Simulator SDK in Unity prior to 2022.3.11f1.
  • Fixed an issue causing incorrect negative scales.
  • Fixed an issue where VR builds would only render to the left eye in device builds when using the built-in pipeline.
  • New template (0.4.3) can be found here.

If you did not previously upgrade to 0.4.1, when you upgrade to 0.4.3, you will need complete the following tasks:

  • After updating to this version, you may need to restart the editor to clear out compilation errors related to upgrading the Unity Collections package.
  • You may need to re-configure “Mixed Reality” mode in Project Settings > XR > visionOS Loader settings

For those who are testing on devices at Apple’s developer labs or via a developer kit, you should only be using the following configuration.

  • Apple Silicon Mac for development
  • Unity 2022 LTS (2022.3.9f1 and above)
  • Xcode 15.1 beta 1
    • Xcode 15 Release Candidate will not work
  • visionOS beta 4 (21N5259k) - SDK

To learn more about Unity’s visionOS beta program, please refer to this post. The following release notes apply to the suite of packages released as part of Unity’s visionOS beta program:

  • com.unity.polyspatial (0.4.3)
  • com.unity.xr.visionos (0.4.3)
  • com.unity.polyspatial.visionos (0.4.3)
  • com.unity.polyspatial.xr (0.4.3)

Known 0.4.3 Issues

  • When running sample Scenes in editor Playmode and navigating to the Object Manipulation Scene, when GameObjects are dragged high above the volume bounds, sometimes GameObjects become suspended without dropping back down to the plane. The GameObjects continue to behave this way until the PlayMode is stopped/restarted.
  • When building and running bundled sample Scenes on visionOS platform and navigating to the Character Navigation Scene, as you move the character around, the entire Scene moves inside the volume across the x and z axis. This causes the Scene content to “disappear” as the edge of the Scene is dragged across along with the Character in the same direction.
  • The Tutorial that was part of previous template versions is not compatible with 0.4.3. Please remove the Tutorial folder under Assets if it comes from a template earlier than 0.4.1.
  • If you encounter errors when upgrading the template from 0.3.3 to 0.4.3, please re-import all assets after upgrading to get around this.

For additional information please visit the General Release Notes.

2 Likes

Thanks for getting this out so quickly. When I try to open 0.4.3 in 2022.3.11f1, I get this warning, “The project you are opening contains compilation errors.” And then asks if I want to enter safe mode. Are we supposed to ignore?

If I ignore, I get these errors, Assets/ExampleAssets/Scripts/Bounded/BoundedInputManager.cs(1,13): error CS0234: The type or namespace name ‘PolySpatial’ does not exist in the namespace ‘Unity’ (are you missing an assembly reference?)

and

Assets/ExampleAssets/Scripts/Bounded/BoundedObjectBehavior.cs(97,34): error CS0246: The type or namespace name ‘SpatialPointerState’ could not be found (are you missing a using directive or an assembly reference?)

If I exit and return, I get the “enter safety mode” error again.

Hey there! These errors seem pretty strange. I assume you’re using the template project, given that these paths look familiar. What version of the template is this? If you revert back to the prior version you were using do the errors go away?

‘PolySpatial’ does not exist in the namespace ‘Unity’ makes me think there was some kind of issue loading the packages. Do you see any errors prior to the compile errors about package resolution or licensing? Do you see PolySpatial under the Packages folder in project view?

Something else to try, if you see the PolySpatial package… right-click on any script in the Runtime folder and choose Reimport. This will tell Unity to recompile the assembly for that script and might get rid of your errors. Alternatively, you can try closing the Editor, deleting Library/ScriptAssemblies or the whole Library folder, and re-opening the project. There might be some sort of stale cache that needs to be cleared.

I don’t yet.

I didn’t see Library/ScriptAssemblies. But I did delete user/Library/Unity and that didn’t change anything.

I was trying to open 0.4.3 but the error persists when I open a fresh download of 0.4.1. That started last night when I removed “com.unity.polyspatial” from 0.4.1 to do the workaround to open the Fully Immersive space.

I got the same sort of error, prompting to open in safe mode, when I attempted to open the visionOS template before I had the coupon for access to the beta. So I wonder if it’s a license issue. In the package manager, under the PolySpatial description, it says “information is unavailable because the package license isn’t registered to your user account.” I’m signed in in the top left corner. VisionOS Beta doesn’t show up under Licenses in Unity Hub but it does show up on the website under My Account, My Seats.

Yeah, that’s the problem.

Whoops! I meant the Library folder in your Unity project. Hopefully ~/Library/Unity is still in your Trash and you can restore it? Otherwise you’ll need to set up your license again and download Asset Store packages, etc. :sweat_smile:

Unfortunately, I’m not super familiar with how to troubleshoot licensing issues like this. I’ll surface this issue internally and get back to you with more info.

There’s another thread where some users with licensing issues were able to figure out some workarounds. You might be able to try some of those.

1 Like

Uh :sweat_smile:

No worries! I’ll work through it with them over there. Thanks for troubleshooting through this with me.

Edit: It was a licensing issue and @IsaacsUnity helped me through it. Thanks again!

This is almost always a license problem .
Go to your xr plugin management and check that you can see vision os there( you probably wont find it)
Go to id.unity.com and yo to myseats , remove any activation of visionosbeta , restart unity hub and re-open the editor from it . That will fix it

Yep, that was the issue! Thank you very much.

1 Like

Hi,

thanks for the update. Unfortunately, I have no-recoverable errors with this new version (and the version before 0.3.3): when I load the template0.4.3 project, I get the following errors:

  • Instance of UnityEditor.XR.VisionOS.VisionOSSettings couldn’t be created because there is no script with that name.
    UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()
  • We were unable to create an instance of the requested type UnityEditor.XR.VisionOS.VisionOSSettings. Please make sure that all packages are updated to support this version of XR Plug-In Management. See the Unity documentation for XR Plug-In Management for information on resolving this issue.
    UnityEditor.EditorApplication:Internal_CallUpdateFunctions () (at /Users/bokken/build/output/unity/unity/Editor/Mono/EditorApplication.cs:362)
  • Apple visionOS XR Plug-in package Initialization not completed. You will need to create any instances of the loaders and settings manually before you can use the intended XR Plug-in Package.
    UnityEditor.EditorApplication:Internal_CallUpdateFunctions () (at /Users/bokken/build/output/unity/unity/Editor/Mono/EditorApplication.cs:362)
    You can check setup in the attached screenshot:

Any help would be appreciated !
Thanks,
Diego

I had the same issue. Selecting all the packages in the Project view, Right-click and select Reimport worked for me.

2 Likes

It worked, thanks !

Hi - My Xcode is 15.1 beta 1 is automatically downloading visionos SDK 21N5259j instead of 21N5259k mentioned in the release notes. Is this going to be a problem? Is there a way to get it download the earlier version? thanks!

1 Like

seems to have worked ok with that new visionos SDK (21N5259j)

Now, my issue is that build fails for 2 unknow errors:

  • BadImageFormatException: Format of the executable (.exe) or library (.dll) is invalid.
    Mono.Cecil.PE.ImageReader.ReadImage () (at :0)
    Mono.Cecil.PE.ImageReader.ReadImage (Mono.Disposable1[T] stream, System.String file_name) (at <a6860a9f6366437387ebdc1f225b7fd4>:0) Mono.Cecil.ModuleDefinition.ReadModule (Mono.Disposable1[T] stream, System.String fileName, Mono.Cecil.ReaderParameters parameters) (at :0)
    Mono.Cecil.ModuleDefinition.ReadModule (System.String fileName, Mono.Cecil.ReaderParameters parameters) (at :0)
    Mono.Cecil.AssemblyDefinition.ReadAssembly (System.String fileName, Mono.Cecil.ReaderParameters parameters) (at :0)
    UnityEditor.AssemblyReferenceChecker.CollectReferences (System.String path, System.Boolean collectMethods, System.Single progressValue, System.Boolean ignoreSystemDlls) (at /Users/bokken/build/output/unity/unity/Editor/Mono/Utils/AssemblyReferenceChecker.cs:128)
    UnityEditor.AssemblyReferenceChecker.GetScriptsHaveMouseEvents (System.String path) (at /Users/bokken/build/output/unity/unity/Editor/Mono/Utils/AssemblyReferenceChecker.cs:325)
    UnityEngine.GUIUtility:ProcessEvent(Int32, IntPtr, Boolean&) (at /Users/bokken/build/output/unity/unity/Modules/IMGUI/GUIUtility.cs:190)
  • Error building Player: 2 errors
  • Build completed with a result of ‘Failed’ in 5 seconds (4727 ms)
    3 errors
    UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&) (at /Users/bokken/build/output/unity/unity/Modules/IMGUI/GUIUtility.cs:190)
    Any idea ? I am stuck there…

thanks,

Hi, does the BadImageFormatException error persist after restarting the editor? There is a known issue when unity.collections gets upgraded from major version 1 to version 2. It might also require a Reimport All, but typically restarting should be sufficient.

I did both and eventually first error vanishes but the 2 other errors stay no matter what…

I’m having issues getting our updated project running on the Simulator since updating from 0.3.3 > 0.4.3.

I followed the guide and I’m not getting any errors when building, but on the Xcode side the Simulator is not showing up as a valid build target, and I’m not able to manually select this.

I haven’t been able to get the 21N5259k version of the simulator as mentioned above. Xcode beta 15.1 itself and the Apple Developer download both point to 21N5259j. I have been able to download the 0.4.3 template project and this will run on 21N5259j without any issues.

I have checked the XR & Polyspatial settings between our project and the template, and there doesn’t appear to be anything different. Is there something obvious that I might be missing that can happen during an update?

For clarity, I was able to build and test our project on the Simulator fine in 0.3.3 using the previous Xcode beta and the 21N5259i simulator, the only change I have made to the project is to download the new packages, as well as copy across the new Bound/Unbounded config files for the Volume Camera.

21N5259k refers to a beta firmware update on the headset. I and J refers to the headset and simulator SDK obtainable through XCode… All three apparently work together. It’s not made clear anywhere and beta firmware updates in general are risky.

-Matt

1 Like