visionOS Release Notes Beta 0.4.3

If it’s useful for anyone else, downgrading the project back to 2022.3.9f1 allowed me to build to the Simulator.

21N5259k refers to a beta firmware update on the headset. I and J refers to the headset and simulator SDK obtainable through XCode… All three apparently work together. It’s not made clear anywhere and beta firmware updates in general are risky.

Thanks for the info on this!

1 Like

NP!, and I think for your original issue of not being able to build to the simulator. Unity changed things with the latest release where in Player settings you need to specify building to either the Simulator vs. Device. It used to be one build would apply to both in XCode but it’s now split up to target different SDKs. Also not super clear.

-Matt

1 Like

Ahh yes! Spot on!

In 2022.3.9f1, the distinction between the Device and Simulator SDK is there, but you can target the Device SDK in the Player settings but it still lets you build in the Simulator.

I checked the template in 2022.3.11f1 and the Player setting is set to the Simulator SDK, so I should be able to update after all :+1:

1 Like

In case this helps, it appears that downgrading the v4 template to v 2022.3.9f1 throws an error about Simulator vs. Device setting which helped us find it. However Unity v 2022.3.11f1 does not and the error on the Xcode side could be clearer.

When running in v 220.3.9f1 this is the error.
BuildFailedException: Unity versions prior to 2022.3.11f1 do not support a Target SDK of anything other than Device SDK. Please change the Target SDK setting in Player Settings to Device SDK.

However, looking in PlayerSettings/TargetSDK is already set to Simulator (v2022.3.9)

We’re still not able to build to the xcode simulator with Unity 2022.3.11f1.
Either with PlayerSettings/TargetSDK set to Simulator SDK or to Device SDK in xcode.

Is there something more we can try or should we focus on Unity 2022.3.9 with PSL v4.3?

We have a lab at Apple on Friday. Want to get our build ready.

The first screen from xcode is the new template with Unity 2022.3.9. The second screen is a new template with Unity 2022.3.11.


Hi , Does any one faced this error while building in xcode ?
Undefined symbol: _GetPolySpatialNativeAPI

unity 2022.3.9f1
xcode 15.1 beta

1 Like

Yes I am getting the same error when building.

1 Like

I’m getting the same _GetPolySpatialNativeAPI linker error when building for device. Xcode 15.1 beta, Unity 2022.3.11 and visionOS beta 4 SDK

1 Like

Same here with Xcode 15.1 beta, Unity 2022.3.9f1 and visionOS beta 4 SDK.

1 Like

Latest word on that is it’s a Unity bug targeting Fully Immersive builds.

-Matt

2 Likes

Thanks for the heads up , so does it mean cant build fully immersive right now ?

Changed the App mode to MixedReality still the same error show up …
Sample project builds fine tho . I moved my whole project into sample project in case that I missed some settings but after building the same error in xcode show up , before importing my files it was building fine with the initial sample demos …

I am also getting the same _GetPolySpatialNativeAPI linker error when trying to build in Xcode 15.1 beta targeting visionOS simulator beta4 (21N5259j) in Fully Immersive Space app mode. Project is in Unity 2022.3.9f1 and was upgraded to PolySpatial 0.4.3.

However, I was able to build and run my app in the visionOS simulator when I chose Mixed Reality mode.

Update: even though my app could start in the visionOS simulator but nothing shows up. I tried another test with the BalloonGallery sample and nothing shows up too.

1 Like

For fully immersive apps I removed the package com.unity.polyspatial.visionos and all seems to be working fine. I’m not sure it is needed for fully immersive builds?

2 Likes

I redeemed my vision OS beta trial on another organization than the license I use, because we have a floating license model where I wasn’t able to add the visionOS trial license to. So I guess I’m out of luck on using this at all?

That shouldn’t make a difference, if the seat is assigned to you , you should be able to see it.
If you cannot see the options to remove the license from within my seats page ( it should be on the bottom inside of a table) , that would he because you are on a free unity license , if you work for a company have them assign to you a pro/enterprise seat,activate it . Once you do you will be able to see that tables inside or my seats. Once you see the table and remove the vision os license , your company can take the pro/enterprise seat back

Hi thanks for the quick reply. I managed to remove the visionOS subscription from my seat, and assigned it again.
The package manager also looks good:

But still the project opens like this (notice that the packages are missing). Which I will post in the next post as I am limited to one image per post :smiley:

Here’s the second image from the previous post

I would appreciate it if I could receive the packages directly in the meantime as this is causing delay for us.

Try restarting the editor.

yeah I restarted the editor a few times

Hi @Jelmer123, can you email us at visionos-beta@unity.com so someone from the team can help?

1 Like