visionOS Release Notes Beta 0.4.3

This looks familiar to me. IIRC A full clean (delete the Library folder) fixed it

Thanks! That solved it for me, the packages are now in the project and compilation errors are gone :slight_smile:

After reading through the forums here and there, I’m left with some questions / problems. Should I create a separate topic for each?

  • building blocks menu not showing in scene. No hamburger menu, and on my Norwegian keyboard there’s no tilde. Although the text says ` but that also doesn’t bring up anything either
  • can fully immersive apps be run in the Xcode visionOS simulator at all? (XR plugin provider: Apple visionOS on, PolySpatial off).
  • In the intro video with Dan, I see many different scenes. These seem to be missing from the template project? There’s only one scene in that project (0.4.3)?
  • There’s conflicting information on what Unity version to use on different pages. Release notes say ONLY 2022.3.5, Unity docs says 2022.23.10, while the example project is on 2022.3.11! Generally I feel like that information is scattered.
1 Like

Fully Immersive App PSL3.4 runs in sim but shows black screen on device. (Posting here b/c we are unable to add a new topic to Discussions.)

We are at the Apple Lab today and our Fully immersive VR App runs in the simulator but not on device. The VR app launches to a full black environment. We get our launch sound, moving the head allows the custom gaze cursor to activate button objects in the world (fully black instead of our rendering). and we can move the Loading Window out of the way.

Using Unity PSL 4.3 template, downgraded to Unity 2023.3.9, removed PolySpatial packages as in another thread, device seed 4 21N5259k. Build Settings / XR Plugin Management / Apple Vision OS Fully Immersive Space. We followed the setup in this thread and it runs on the simulator.

Anyone else able to run fully immersive apps on device with PSL 4.3 ? We just have 1/2 day left here. It would be great to see it on device.

1 Like

Throwing a hail mary , i think you’re using a custom renderer , go to your settings folder ( or w.e folder you put your render in ) , click on that renderer , click on " Add render features " , and choose AR background render .

I tried to open the project again, which I had open earlier this afternoon. But the polyspatial packages have magically disappeared again from the project. Nothing here really works for me unfortunately, although i understand this is pre alpha. I have 5 years experience with HoloLens, Quest & ARKit development :confused:

read my previous replies on how to fix the packages issues : 📌 visionOS Release Notes Beta 0.4.3 - #8

Thanks @charbel_unity65 We’re not using any custom renderers that I know of. We converted everything to URP. I’m able to run in the simulator if I removed all the PSL packages. But on device we get audio but other than the loading window we get blackness.

I saw that, it worked. I suppose I have to do that every time I open the project then…

1 Like

it almost always happens when you switch to a different inet , not every time you open the project

1 Like

Thanks @charbel_unity65 that did get rid of the black on the device. I see the video passthrough instead. But now no audio or activating even invisible buttons (still no image of our content). Guess we’ll wait for PSL5. I’m going to move on to our mixed reality app. That at least does load on device. Appreciate the fast response!

Hi, I am trying to record from the microphone using the Microphone class, but running in simulator gives me: Starting microphone failed: "An error occurred trying to initialize the recording device. " (70)

Code: Microphone.Start(Microphone.devices[0], false, 10, 44100);

I made sure that permissions are granted in Info.plist. Am I doing something wrong or is this not implemented yet?

Thanks!

when is the license bug going to be fixed? And is that a Unity Editor problem or the template project?

It’s quite a process to remove and reassign seats, and just to be sure, delete the library folder as well, just to work on a project… I understand that this is a beta but this one is pretty rough :smiley:

Unfortunately I can’t get it to work today. Tried:

  • download template project from scratch (0.4.3)
  • close Unity Hub
  • log in to Unity ID online
  • revoke Apple VisionOS Beta
  • assign Apple VisionOS Beta
  • open Unity Hub
  • Open the project in Unity 2022.3.11 (as per project template)
  • Result: NO PACKAGES.

What am I doing wrong?

I also tried:

  • Close Unity Editor
  • Close Unity Hub
  • Delete Library folder in the template project
  • Start Unity Hub
  • Open Project
  • Still no packages.

I guess I’ll use my time on Swift again

I am doing it slightly different. Don’t know if it works for you:

  • Revoke Apple VisionOS
  • Click Manage Licenses in Unity Hub
  • Click Refresh

This should auto-generate your seat again.

1 Like

Thanks, unfortunately nothing is visible there as we have our own floating license server and unity hub is not completely up to date with that option.
But do you see the visionOS beta license there?

Yes, it appears in the hub for me… :thinking:

Still no luck today. @Unity: is there a timeline to fix this issue? So we can plan accordingly…

Hello Jelmer, I’ll follow up with you directly via email. Thanks for reaching out!