VisionPro, PlaneManager doesn`t generate any planes

Plane manger doesn`t generate any planes on a real Vision Pro device.
I used mixed reality samples to create a scene and also created my own using plane generation. I set up the scene with AR session, volume camera, and a few buttons like activate plane detection.

In the sample scene, I was able to spawn objects around me, but planes were not generated. I tried to move around to track more space, but planes didn’t appear.
Unity 2022.3.5f1

  • unbounded mode in scene;
  • unbounded mode in settings;
    XCode 15 beta 2
    VisionPro seed1

We recently found a bug related to planes and meshes that require both to be enabled in the scene. Can you try having a single scene with an ARPlaneManager and an ARMeshManager setup at the same time?

Hi, @DanMillerU3D. I tried different setup of the scene:
First both ARPlaneManager and an ARMeshManager in the scene:

  • ARPlaneManager → none , ARMeshManager disabled,
    (have buttons in scene and set Vertical/Horizontal/Both or enable ARMeshManager).
    Tried different variants (with ARPlaneManager), nothing. When I try to enable ARMeshManager, a crash occurs.
  • ARPlaneManager → horizontal/Vertical, ARMeshManager disabled, nothing;
  • ARPlaneManager → horizontal/Vertical, ARMeshManager enable, crash as on image above;
  • ARPlaneManager → none, ARMeshManager enable, crash as on image above;

The next set up scene only with ARMeshManager:

  • ARMeshManager disabled, nothing, enable in runtime → crash;
  • ARMeshManager enable as default, crash as on image above;

The next set up scene only with ARPlaneManager, different combination and nothing;

  • ARPlaneManager → none , (have buttons in scene and set Vertical/Horizontal/Both). Tried different variants (with ARPlaneManager), nothing.
  • ARPlaneManager → horizontal/Vertical set as default, nothing;

Tried with different version of PolySpatial: 0.1.0 first and second with 0.1.2. Result the same.

Thanks I’ve noted this information, do you see any errors in the xcode console when a build doesn’t crash?

The next package release should enable planes and mesh on visionOS seed 2 but does have the above bug I mentioned (requiring both to be enabled).

Sounds great. Do you have visibility on when this update will be released? We will be back testing on device next week again Sept. 6th.

The latest packages (0.2.2) have been released that support visionOS seed 2 along with xcode 15 beta 5.

Thanks @DanMillerU3D, I will check and back.

@DanMillerU3D, checked on seed2 in next configuration:
*Unity 2022.3.5 *
Xcode 15 beta 5
PolySpatial 0.2.2
and it’s working. Thank you for your support.

1 Like