Visual glitches in editor when using URP

I've been using Unity in Ubuntu for some time (using the builtin pipeline) and everything works fine.
Yesterday created a new project with URP and this is how the editor looks (it's an empty project created using the template provided by unity hub):

And when the mouse moves over the editor Scene window these glitches change visually.

If looks good when:
- run from the editor
- build the project and run the binary

Any ideas on why is this happening?

Does switching graphics API between vulkan and openGL Core fix it?

This clearly isn't supposed to be happening. I suggest making a video of it and then make a big report in the project with the video added as a file. Also testing on other unity versions might be helpful

I've tried with Vulkan, but (as far as I know) that's a project setting, not for the editor.
Is there a way to make the editor use vulkan?

The current desktop API will restart Unity and launch it with that API. You can see it in the top (your screenshot has opengl 4.5).

The editor didn't restart and after closing the project and reopening it still says OpenGL and I've checked Vulkan appears first on the Graphics API option.

Then I’m out of ideas. Maybe file a bug report if you haven’t already

I found the same problem today (switching to Vulkan made my project crash). Did you find a solution?

Didn't found any solutions, I'm using the builtin render pipeline now

i found the same bug is there a fix for this ?

Haven't tried again and moved to Windows since then.