visual studio 2017 auto complete is so irritating

I used to use monodevelope instead of visual studio 2017, and I recently started to use visual studio.
There was many many upgrades since I changed, but there’s a big problem that I cannot figure out the solution.

The VS auto complete system always makes me angry whenever I try to make a new function.
For Example:
void Move()
{

}

this what I normaly write but in Visual Studio it just automaticaly change it to:

privat void OnAnimatorMove()
{

}

Now, I know that adding ‘private’ doesn’t really matter, but it is really irritating that it alway change my new function name.
Is there any great solution to this problem?

Oh forgot important thing to say:
I would really like it if the solution doesn’t involve turning the entire autocomplete function off. I LIKE autocomplete. It is problem only when I write a new function.

Well you have generally two solutions you can pick from:

  • If you like to get autocompletion for Unity messages you have to just cancel autocompletion before you write your opening bracket after your method name. To cancel autocompletion you just have to press “ESC”
  • If you don’t need / want the autocompletion for Unity messages you can just disable them in the settings of the Unity Tools plugin in Visual Studio:

Note that disabling this option does not disable autocompletion in general. Just the additional messages. Since the Unity messages are not part of a base class or anything they implemented this autocomplete feature in the Unity Tools for Visual Studio.

Its intended functionality based on the settings you have. You are auto completing to Unitys messages. You can turn that off specifically though.

In VS go to Tools → Options → Tools for Unity → General. Change “Unity Messages code completion” to false if you want the functionality you are talking about.

Image provided.

Edit : After changing this, restart visual studio.