Visual Studio has stopped listing my Android device for debugging

Hi all,

I know a number of similar questions have been asked but I have tried their suggestions and still have the problem. I suspect the cause of my issue may be different.

I’m developing an Android app on my Windows PC. Up until a few days a go I was able to debug my app from Visual Studio by;

  • Connecting my android device to WiFi.
  • Building and running my app from Unity with the “Development Build” and “Script Debugging” options
  • In Visual Studio, going to Debug->Attach Unity Debugger.

That window would list two instances, the first would always be the Unity editor running on my PC, the second would the app on my android device. Now when I try this, only the editor is listed.

I have tried completely uninstalling Unity, Visual Studio and the Android SDK and reinstalling them. No luck. I have tried 3 different Android devices. Still no luck.

However if I try this same procedure with my laptop, rather than my desktop, it works fine. This suggests there is some setting I have messed up that somehow persisted through my re-installs.

Any advice would be gratefully received!

Any solutions found?
Can not see any android option in VS or Monodevelop even everything setup and phone debugging enabled - tried same wifi etc