Visual Studio Login Problem

Unity nicely added the Visual Studio for scripting, that forces a login for work with it.

Begrudgingly I registrated by Microsoft just to see, that VS wont accept my login anyway.

It just says: “Sorry, we ran into a problem”
I have two links for checking the problem, and both are leading to a site, that says “Everything is looking good”

What can I do? I can’t find a specific solution in the web. I’m feeling fooled…

Well, after some hours of investigation (my english as a swiss isn’t that good, i had a lot to read), I’ve found the issue.

Short: I solved it by installing the Microsoft Internet Explorer 11.

For some reasons, this Microsoft product just wants to use the original IE11 for that internal activation (the IE didn’t pop up, but is needed, it seems). As a win7 user I just had the IE8; I don’t undestand, why the kind of the explorer you use is importand for the licence registration (every link opened by Visualstudio worked fine with my current explorer)…