Visual Studio's 'Attach to Unity' replaced with standard 'Attach...' and will not attach to Unity properly

Issue:

When I click “Attach…” in Visual Studio, I get a list of all processes running on the computer and am asked which to attach to. I’ve tried both Unity.exe and UnityHelper.exe, but those don’t seem to do what I’m looking to do. I know that the correct button is supposed to be “Attach to Unity”, with no dialog box on click.


Data:

Unity 5.3.1f Personal

“Microsoft Visual Studio Tools for Unity 2.2.0.0 enabled” in Help → About

Double clicking a script in Unity opens the project in Visual Studio Community 2015 (Visual Studio Express 2015 for Desktop is also installed on the machine.)

Have tried both with and without the UnityVS folder in my project. This doesn’t seem to effect anything.

C:\Program Files (x86)\Microsoft Visual Studio Tools for Unity\2015\Editor\SyntaxTree.VisualStudio.Unity.Bridge.dll (2013 version also present in …\2013\Editor)

C:\Program Files (x86)\Microsoft Visual Studio Tools for Unity\2015\Editor\SyntaxTree.VisualStudio.Unity.Messaging.dll (2013 version also present in …\2013\Editor)

Registry points to 2015 version of Bridge.dll


Attempted:

I’ve done numerous internet searches to know to check most of the above things, but the problems I’m seeing people having are from Unity to Visual Studio. I did used to have the bug that caused MonoDevelop to try (and fail) to open instead of Visual Studio when double clicking a script, but that’s been fixed for quite a while. The problem I’m having now is is the reverse, Visual Studio to Unity. I’ve ignored it for a while as I’ve been able to get by debugging with "print()"s and the inspector, but now I’m faced with a bug that this method of debugging doesn’t work for. I need to attach to look at exactly what is going on and am not finding anything online on how to fix this.

I’ve tried re-running installers and “repairing” installations… And of course a simple restart… I’ve also tried deleting everything from the project’s folder except for Assets & ProjectSettings and letting Unity recreate it all… But these have also led me nowhere.

I was previously using Visual Studio Express 2015 for desktop. I’ve switched to Visual Studio Community 2015 while debugging this. One thing that I’ve just noticed now that I’m trying to work in it is that the Solution Explorer states that MyGame.CSharp and MyGame.CSharp.Plugins are both incompatible with the current edition. This is after Unity remade the files. I would assume that this is another symptom of the issue causing the issue that this question is asking about, so I’ve added it.


Any more ideas? Anything else I should check that I haven’t yet?

To give an update on this & close the thread… I uninstalled everything & reinstalled it. It’s crappy that that’s what I had to do, but there was no data anywhere on performing a proper fix, so I had to take the sledgehammer approach.

Thanks anyway…