Volume rolloff not working in game mode

I have a audio source playing music in my scene and an audio listener on my first person controller. When i’m in scene mode, everything works as it should. Volume drops when i move the camera away from the source. But when i play the game, the volume is constant no matter where i stand. I don’t get any error for multiple listeners in the scene either. Any suggestions?

I didn’t set the “output” on the audio source. The output needs to be an audio mixer for the 3d sounds to work. Not setting an output will send the sound directly to the listener. Not sure why it worked in scene view…

As far as I can tell an audio mixer is not required. The audio source’s Output can be set to None.

The only critical thing to note is that the “Spatial Blend” property on the audio source needs to be set to 1.