VR UI Render Issue

I am currently working on a Unity VR project, using the Unity XR toolkit and an Oculus Quest 2 device. The Unity version that I am using is 2021.3.22f1. Everything in my project was working until last week. However when I was testing my project today, I encountered this issue where the UI elements in scene are only being rendered for the left eye of my quest device and not the right, the rest of the 3D models in the scene are rendered properly, it’s only the UI elements that are causing a problem.
In order to make sure that there is nothing wrong with the device itself, I tried a previous build and it works perfectly.
The only change that I have made in project is I have created a new scene with some new UI elements. As far as the canvas settings go, it is set to world space and it is present on the UI layer. The UI layer is set to render for the main camera in the XR origin game object.

Maybe you changed to multiview (which should be better than multipass). Using another shader on the UI might help.
Could you try the latest 2021 version as well?

I am currently testing the build on PC and this is the setting that I have.

I also have the default shader for UI
9816474--1410660--upload_2024-5-6_11-54-11.png

For better understanding of the problem you can take a look at this video -

Thank you for the help.

I will try using the latest 2021 version to see if it helps

I tried the project with latest 2021 version and the problem still persists, and I am getting this error statement whenever I start my game.

RenderingCommandBuffer: shader Hidden/Internal-Loading: invalid pass index 1 in DrawProcedural
UnityEngine.GUIUtilityProcessEvent (int,intptr,bool&)

Are you using version control (like git)? If yes, compare if anything changed. If not, I would highly recommend as soon as you fix this issue to start using git (and potentially a free GUI tool like SourceTree) to track your changes. I had a similar issue in the past where an unknown change to my project (not by myself, perhaps updating Unity or some other asset) had severe effects that I was only able to see using git.

1 Like