[VRDevice] Initialization of device oculus failed

I’ve been developing my first Android app (Gear VR) over the last month or so - progress was great! Until I allowed an Oculus update on the target device (Samsung S7, non edge model). Since doing so, I have been unable to create another working build for the Android.

Here’s where I am now:

  1. Updated the Oculus runtime on my PC to version 1.3. (Assumed working OK, as I can see Oculus Home on my DK2)
  2. Updated my PC graphics card drivers (now running version 368.22 on my GTX 980)
  3. Updated Unity (now using version 5.3.5.f1 Personal Edition)
  4. In Unity project, removed the old OVR Camera and replaced with a standard Camera

When I try to run my project my Oculus doesn’t activate. In the console I get:

  • a list of 7 warnings, all along the lines of “VR: Oculus could not be loaded: Failed to load symbol ovrp_xxxx”
  • An error: [VRDevice] Initialization of device oculus failed.

I’ve not even tried building and running on the Android device yet, as there’s clearly serious issues just trying to run it on my PC / DK2 with version 1.3 of the runtime.

I’ve seen many other forum posts where developers are reporting similar issues, but so far nobody seems to have found a working Unity configuration for Oculus runtime 1.3 and the DK2.

Any help anyone?

Did you fix this? I have the same issue…

Yep, I got it fixed. The recommended SDK versions on the version compatibility page only worked for me when I tried with Unity 5.4 beta. (Compatibility page here: Not Found | Oculus)