VSync won't disable

Okay, so I have a problem with VSync in my project that just randomly started and won’t go away. I even tried rolling back changes I had made to identify it, but nothing will get rid of it. As you can see in the screenshots below, WaitForTargetFPS and Gfx.WaitForPresent are taking up 15+ ms each frame, even though I have vsync turned off in project settings, and I don’t touch the Application.targetFrameRate variable anywhere. Also, the stats window shows my rendering thread is running at 0.5ms/frame, and without the limiting stuff, my cpu side would run at 0.5-1.0ms/frame. How do I get Unity to stop limiting me?

I’ve read a number of other answers, but each of them suggested doing things my project is already doing, as I explained above.

First of all make sure you turned the vsync off in the correct quality setting and that you’re actually using that setting when testing.

Apart from that it’s possible that your GPU has a force override set in the driver settings. NVidia for example allows you to set global overrides as well as application specific overrides.

ok for me looks like changing the target frame rate force vsync to be enabled ;

i removed this lane of code :

“Application.targetFrameRate = 60;”

and every thing got back to normal ( a unity restart is required )