Vuforia 10.4.4 doesnt appear to be importing

Hi All.

I just got a new laptop and installed Unity Hub 3.0.1 and Editor 2020.3.28f1. I had projects from 2020.3.27f1 that used Vuforia and worked well. I updated project but received errors that Vuforia namespace doesnt exist in a few scripting files. I’m not sure of how Unity stores a package so this made sense this laptop never had Vuforia package imported which probably registers even though it was imported to existing project and folders are still there.

So I went into package manager and sure enough Vuforia is not listed as being in this project? Clicked on My Assets and downloaded Vuforia 10.4.4 to import. This informs me to install/update which in turn brings up Import Unity Package window with a long list of folders and files of which only 1 file is checked under project settings. I tried to click a few files I recognize and folders, however I quickly get a checkmark but then it disappears. I click import and it runs for a few seconds and is done but I get no feedback that it did anything and going back to packages in project Vuforia is not listed. I tired it again and clicked the All button and import and same thing a few seconds but nothing reported.

Any ideas why this is happening and why I cannot click on files to import as I am assuming that nothing being selected is the issue.



FYI: I decided to create a new project and import Vuforia successfully and move assets into this new project. Working well now.