warning about the new update to unity hub!

so, you might want to consider reinstalling your unity hub after the update. Mine completely broke. Not here for help, just warning those who haven't updated. It might come down to specs or something.

What was the bug? And what broke? Please don’t tell people to just “reinstall” without giving any context.

Unity Editor 2022.2.2f1 (linux) crashes for me on startup. I’ve tried reinstalling the hub but no change. I’ve also been searching for some kind of generic “how to get your project back if the editor keeps crashing” advice but I have not yet found anything. FWIW I was working on a HDRP shader graph the last time I was in the project before I upgraded. I’m fairly new to Unity and right now my project is a dead black hole. :frowning:

Base path: '/home/mgb/Unity/Hub/Editor/2022.2.2f1/Editor/Data', plugins path '/home/mgb/Unity/Hub/Editor/2022.2.2f1/Editor/Data/PlaybackEngines'
Cmd: initializeCompiler

Unhandled exception: Protocol error - failed to read magic number (error -2147483644, transferred 0/4)

Quitting shader compiler process

FWIW deleting the Library folder and the shader graph got the editor to start up. However my hierarchy had lost everything but a default camera and light. I created a game object and attached a script and it actually worked but then a minute or so later the editor crashed again with the “failed to read magic number” error. Reimported all and again the hierarchy was reset to one camera and one light.

I’m going to have to go back to a backup and 2022.2.1f1.

Did you re-open the scene you were working on? It might have forgotten which scene you were editing.

You may well be right. Thank you. I’m fairly new to Unity and didn’t check that. However even with a single game object it crashed again within minutes with that magic number error so I rolled back to 2022.2.1f1.

it just told me “unity hub had a critical error” after opening, reinstalling fixed the issue comepletely.

its the unity HUB not editor

I’m talking about unity hub here.

I’m not the person to help. @Kurt-Dekker @BABIA_GameStudio @Yoreki please help this guy

No need. I’m happy back on the previous version.

It seems I mistakenly hijacked your thread, for which I apologize.

oh, make sure you read all the way through and make sure its about the editor next time. Its all good