Web player fails to download data file, IIS 7, MIME problem? hosted at EasySpace.com

I am using windows 7 64, i have my web hosting in EasySpace somewhere in Glasgow, and the server is based on windows(i think) .My problem is that uploading in my ftp a .unity3d file with the corresponding html doesn't play.(web player failed to download data)

I don't know anything about servers etc apart from writing basic html ... What I tried so far after checking forums and unity answers is ...

A.i added a web.config file declaring application/vnd.unity in my root directory of my web site. It didn't work.

B.I tried to rename the unity file to another name like jpg. It didn't work.

C.I contacted EasySpace to get an answer, Still waiting....

D. I tried to connect with IIS 7 to my website but don't really understand how it works. Do i have to connect to my local directory and then pass the permissions on the easy space server?

Any help would be really appreciated. Do i have to pay another hosting provider ?

thanks in advance alex …

Finally after easyspace.com fixed mime settings and move my files to a linux server everything works perfectly now ... I don't know what was the problem but my webserver was in an old windows machine.

I had same problem. Reason was simple incorrect naming of files, casing also is important.
you should edit your html file
and check if
unityObject.embedUnity(“unityPlayer”, “webplayer.unity3d”, 800, 600);
have same name as your .unity3d package.

Though its a pretty old question: See the following topic. It is exactly what has to be done to enable downloading of unity3d files if you are able to config your server on your own. Just add the correct MIME type in the configs of the webserver