Web-Player will not install on Google Chrome

I’ve been trying for hours to get web-player to install on chrome and even though the installer goes through the process with no problems, it keeps on telling me that the unity web-player isn’t installed.

It works perfectly on firefox and IE… but not Chrome.
I tried googling for the answer and could not find one that worked.

What could be going wrong? ;/

,in Chrome v42 they have disabled the NPAPI support, but the good news is you can enable it again.

  1. Paste this into chrome: chrome://flags/#enable-npapi
  2. Hit activate on that item
  3. also activate native-client underneath.
  4. Bingo Unity works again :slight_smile:

Chrome is depreciating plug ins:

More here:

And here:

It can support the the NPAPI plugins!

in chrome type: chrome://flags/

Go down and find Enable NPAPI Mac, Windows

Enable it and restart chrome.


went to plug ins -manage exceptions -entered unity download address -and clicked allow-for some reason it is now working and appears on plug ins page

Chrome is moving to depreciate all web plugins in Chrome. These posts have more:

went to plug ins -manage exceptions
-entered unity download address -and clicked allow-for some reason it is
now working and appears on plug ins

This No Longer Works Version 4.3 Webplayer is Dead and Actually really messes with windows 7. I have to reboot after attempting to play a Unity Game.

Just made it work,

  1. I went to chrome://plugins/
  2. Look for unity player
  3. Click on Enable

After that it started working!

Having a similar issue… Installation suggests “Unitybugreport could not install” so there is NO UNITY installed!

Unity Web Player Fix that worked for me
Unity Web Players sometimes gets corrupted due to multiple version installation.
A Quick fix for Unity Web Player is to install a cab version
1 Uninstall the old Unity Web Player
2 Download the Cab,
3 Extract the data,
4 Bring both the setup information and the exe to the same location in a folder
5 and Install


Please Be Aware
… of the ever changing state of this depreciation.

GO to the Google Website
… and find out what is the current news depending upon when you read this.

Chrome is planning on completely removing support for NPAPI and therefor the Unity Plugin.

Currently, Google is the only company and Chrome is the only browser actively depreciating this technology.

It seems that we have to gradually left Unity Web Player behind and embrace the WebGL development since running native code in browsers may not be supported at all anytime soon. For now it’s only Chrome, yes, but despite its recent decreasing in users’ numbers, it still holds more than 40% of the share, what is three times more than any of its competitors and more than IE, Firefox and Safari all combined.

Meanwhile, try to keep your public playing through the still supported Web browsers and try your best to port your project to WebGL.

After having many problems and headaches with Unity Web Player and different browsers, I then decided to throw the towel and start researching about other ways to get my content to the Web game players.

Unity needs to make some announcement concerning this. Some developer rely on users being able to view the content they create on the most popular browser out there. It’s a bit much to ask everybody to switch browsers and exceptionally bad when a project developed for a client no longer works. Can be a real business killer.
We can’t ask thousands of end users to mess with their chrome settings. We need to know what Unity is doing about the problem and when it’s going to be done, even if the answer is “nothing”. Is it possible to use a different installation technique? This is the kind of thing that Unity needs to get on top of before it turns into lots of bad posts on social sites, if it hasn’t already.

Please check the unity blogs. This has been discussed extensively. This is. It breaking news and has been on the roadmap for years.

You can fix it easily by integrating “Video Player” in Google Chrome.

Some time this messge appear “unity player need permission to run”
then flow this link