WebGL Build issues with Unity 2020.1.2f1

Hey guys,

I just made a build of a game I was working on and attempted to upload it on Itch. But when I clicked on “Play Game” on the Itch page, all that showed was a black screen where the game was supposed to be. I tried redoing the build a couple times, with no change. There were no console errors by the way. Then I tried running the project on a earlier version. That was a real chore, as I got a bunch of package related errors. But once I resolved those errors, the build I made worked on Itch.
So it has to be an issue with Unity 2020.1.2f1. But I can find nothing about it when I google it. How is this possible. This version has been out for a little while now. Surely someone must have tried to do a WebGL build and had the same problem I had.
Does anyone have any information on this?

I have 2020.1.15 and I have a similar problem. Runs in the editor and with a Mac build, and “Successful” build for WebGL, but it won’t start with Safari, Chrome, or Firefox.