WebGL Shading Problems, Ignored Sliders, Normalmaps

Hello,

I have been struggling to get my WebGL Project up and running because it seems impossible to me to get the same Quality in WebGL as in the Editor.

NORMALMAP
First of all, the Issue with the normalmaps are well known. It has not been fixed in 5.3.04f. Im getting big artifacts and the normal slider in the Standard Shader has no influence. It will always be set to 1, so for those who have the same problem, just set the influence to 1 by default and try to adjust the Normalmap (adjust Contrast of Image) or use the bumpiness slider if the normalmap is beeing created by a grayscale image.

Also it seems the Normamap works als long as there is no Reflection from a Sky/Cubemap or one uses the legacy shaders. Also just using Dynamic Lights seem to work. ??

LIGHTNING IN EDITOR DIFFERENT TO WEBGL
Using only Baked GI and Non-Directional Mode, the only way to get the same Results in WebGL an the Editor is setting the Reflection Intensity to 1. Otherwise the Editor is always brighter than the WebGL version.

CAN SOMEONE TELL ME WHAT SLIDERS HAVE INFLUENCES IN WEBGL AND WHICH DON’T ? (in Material, Refelction Probe, Lighting Panel)

SHADING ARTIFACTS


These got worse since version 5.3. It seems that the Polygonal Structure is shining through. The Image shows a pure Standard Material.

If someone found any answers, solutions or workarounds, please let me know.
THANKS !

I fixed the Shading Articats by changing my Mesh-Struckture, but the Phong Shading seems to have a problem never the less. This again doesn’t seem to be a problem when I use a legacy shader.