webplayer Chrome not working, Firefox ok


I’ve noticed that my Unity projects in my site www.astragamingstudios.tk don’t work when I use Chrome. They do work when I use Firefox. Other Unity projects on other sites do work. My friend is experiencing the same on his laptop.

My site is a standard Google sites.
I use Windows 7, Chrome Version 22.0.1229.79 m, Firefox 12.0.

Could it be the newer webplayer isn’t compatible with older web builds?

Hi Boi,

Okay, don’t worry about sending us a bug report, I managed to find the offending error:

If you launch developer tools and click the console, you will see a warning which says it’s blocking UnityObject: “ran insecure content from http://webplayer.unity3d.com/download_webplayer-3.x/3.0/uo/UnityObject.js.

This line of html on your page:

“iframe title=“Unity 3.3 gadget (1.004)” width=“800” height=“600” scrolling=“no” frameborder=“0” id=“1655576568” name=“1655576568” allowtransparency=“true” class=“igm”> src=”//":

You missed out the protocol in src=“//” so to fix it should be src="http://b

Or if you want to keep https, you can just link to our https UnityObject file using this link:

https://ssl-webplayer.unity3d.com/download_webplayer-3.x/3.0/uo/UnityObject.js instead of the one your using



Usually a web player is placed into the page using JavaScript fetched from the Unity3d.com website. This JS file is called UnityObject.js (or UnityObject2.js for 4.x content). You can see the source for this if you make an offline build of the game. Open this script in a text file. Search for ssl and you’ll find:

useSSL = (document.location.protocol == ‘https:’), //This will turn off enableUnityAnalytics, since enableUnityAnalytics don’t have a https version.
baseDomain = useSSL ? “https://ssl-webplayer.unity3d.com/” : “http://webplayer.unity3d.com/”,

This shows you how UnityObject.js handles the choice between a regular http site, and a secure site hosted on a https protocol.

In your website, you appear to be running on an https site. Your html seems to use a Google gadget. You may need to contact whoever created this gadget and ask how it is meant to handle content coming from an http site when the webpage is hosted on a https site. I would recommend, however, using the UnityObject.js/UnityObject2.js to get the content onto the page. This JS also handles installing the plugin if the user does not have it already. I do not know if this is compatible with Google sites, however.

Hi Boi,

Could be a server issue but I’m only guessing here, what do you mean by “don’t work”, what actually happens? Please file a bug report on this and provide screenshots and video’s. I looked on your website and I couldn’t find any games, please link to them in the bug report.


The term “games” is somewhat misleading I suppose. I have several Unity projects I use in my classes (AI, AR, multiplayer, …). Most of them are small mini-games. For example Space Invaders 3D (an actual game) which is under “Unity 3D games 'n demos”. This works fine in Firefox, but Chrome keeps telling me to install the webplayer. I can play other Unity games from other sites in Chrome, so I don’t think that is the issue. Any help is welcome.

What Space Invaders 3D looks like in Firefox: Firefox

What Space Invaders 3D looks like in Chrome: Chrome

Looks like you are hosting your game in a “https” (secured) server. I had exactly this problem too, and the only solution I found is to host it in a non-secured server (“http”).

Edit: Actually, there is a way to make it work, you just need to change the scripts references. You can get a gadget to use https references here. While you can use the gadget from the link, I do recommend that you copy and re-host it since I can’t guarantee the link availability.

Hi - I’m more than a little concerned about previous carefully written messages being missing, but I do have a partial solution that worked for my configuration.

Logging on as a new user on windows, downloading chrome browser on that ID, and fresh plugin worked for me, while my main dev account still gave the same problem - not installed. Obviously not the javascript or protocol, permissions or other suggestions.

I then totally uninstalled chrome, (archived first in case it didn’t work) deleted appdata/local/google/chrome/user data completely and reinstalled chrome. No luck. Problem is certainly stubborn and probably exists in windows user configuration (somewhere) This is taking a disproportionate time to locate, but at least new user is better than a format. It’s far from perfect, there should be an easier way - I’ll keep looking for a while (but am currently more likely to switch to the clean user, sigh)

Ah, same visual, completely different problem :slight_smile:

I just tested on one of my google sites, and got unity running very quickly. I inserted “Include gadget (iframe)” and linked that to an externally hosted page generated directly from unity and it worked first time. Not as elegant as a custom gadget, but hopefully easier to fiddle with. Hope it works with dropbox or similar for you.