WebPlayer does not work after upgrade

Problem:

I have had a variety of versions of Unity on this machine over the years (WinXP SP3)

how do I completely remove all references to the Web Player from my machine so I can install it afresh? Something is not being properly removed by the uninstall, so the player is currently completely borked (looks for missing files in wrong locations, at the least)

alternatively, where do I find a fully offline installer, so it actually creates all the files it needs without trying to pull them off the web?

Background:

at some point in the distant past, I upgraded to 4.3 and it stopped working, although I got it to run with some effort (mostly by using the “full” installer for an older version, and renaming/copying some files to the location where the software is looking for them - see log snippet at the end of this post). the Player folder doesn’t even exist under WebPlayer, and webplayer_win.dll does not exist anywhere on my machine after installing.

if I use the full installer from 4.3 and copy some files around, it could launch games, but they are covered with a black box and/or do not draw anything (can’t tell which), which is probably a side effect of severe version incompatibility, and nothing is actually playable.

I have closed all browsers, uninstalled all Unity software, rebooted, reinstalled the webplayer from the Unity website, still doesn’t work.

Please help!

Log snippet:

141029 10:03:59 Instance starting, version 4.5.5f1_7684ad0c5a44, UNITY_WEB_ENABLE_AUTODOWNLOAD: 1, GetDisableAutoUpdates(): 1
[trimmed]
141029 10:04:00 loader: unity dll not found: C:/Documents and Settings/Zzz/Local Settings/Application Data/Unity/WebPlayer/player/Stable3.x.x/webplayer_win.dll

oh god, this is probably the worst-designed system known to man.
here’s how i finally fixed it:

  • build a new VM (or just find a totally clean machine)
  • install Unity Web Player. this will NOT create the Player or Mono folders
  • going to the Unity site to check stats only creates the Player folder, but not the Mono one. annoying.
  • Tried playing a game that finally got me the Mono folder but errors out. Checked logs - it can’t download http://webplayer.unity3d.com//autodownload_webplugin-3.x/UnityPlayer3.x.x-win32.zip
  • downloaded that by hand, overwrote the files in the Player folder with that, refreshed the page a few times, poked it until it worked, then copied the resulting Player and Mono (and everything else for good measure) back to my real machine.

for god’s sake, was it so hard to make one installer that actually installs everything by itself, and actually works, and doesn’t error out if auto-update fails?