Webplayer Fails to update error, latest version installed

I have 5.3.3f1 of the web player installed but when running unity webplayer apps (even simple scenes of just two boxes with no plugins etc) fail to load.

I get the error Failed to update Unity Web Player, error details “A newer version of Unity Web Player is required, but the auto-update failed. Invalid auto-update file format. Please install manually.”

I get this on 5 different computers. Last week I ran a build tested it, worked, than ran it again and it stopped working. I have tested the apps on a computer without internet connection and it does work (I installed the webplayer by downloading the full installer from unity).

Is there any solution to this?

So I found a link to the webplayers for 5.3.1 and 5.3.2. I installed the 5.3.2 web player everything is working fine.

Seems that 5.3.3 did not play with my 5.3.2 build. I am not certain exactly what the issue was, but all is well and happy now.

Here are the offline installers for the webplayers