Weird behavior - pink sprite

Unity - 5.2.1f1 Personal, OS - Win 8.1 64 bit
I have a 2D scene (Main Menu) with some sprites with “Sprite/Diffuse” shaders (for 2D lighting), and others are “Sprites-Default” (I don’t want any lighting on them). Everything is fine when I run in the editor.
Now, when I create a windows x86_64 build and start the game still everything is great on the Main Menu, but when I come back again to main menu all my “Sprites-Default” sprites are pink.
I did go through a lot of help and tried different things, but it does not seem to work.
Any help would be great.

Cheers!

I’ve found the issue. The culprit is - “Super Tilemap Editor” (Unity Asset Store - The Best Assets for Game Making), it destroys the Material used, that’s why any other scene using it shows pink.
TileMap.cs:
Line 338: DestroyImmediate(m_material);

Just commenting this line resolves the problem (not the right solution though), I don’t understand why it was not tested by the good folks @CreativeSpore, it’s even weirder as this is a popular asset.