Weird line in my grass textures?

Every time I make a grass texture and paint with it, a weird line keeps showing up on the left side of the image (it's yellow, sometimes black). I've checked to make sure there's nothing actually there in Photoshop, tried making multiple different files saved different ways... and nothing. It still gives me that stupid line. alt text

Anyone have any idea why this is happening? :/

UPDATE: I don't know if this is the cause or not, but I know a lot of times you have a background color under the foliage/grass/whatever that's similar in color to help prevent weird/glowing outlines around the foliage/grass/whatever. I wasn't thinking about that since the issue is so far from the subject of the texture, but I haven't been doing this. I've been having issues keeping the alpha intact when I add a background color on another layer. If anyone could help me with saving the file out of Photoshop properly (we're using .png), I can at least see if this helps.

While I wait to see if I get an answer to the above and see if it helps, I have found a temporary "fix." I just applied the texture to a poly plane with its UVs slightly smaller than max, so it cuts off the line, and I loaded it as a detail object instead of grass. From some angles you can still see a small line, and this isn't the most ideal solution, but it works well enough for now. I have other fish to fry and will just have to revisit the issue later.

All the maps for grass and detail objects are compiled into one map. If you have detail textures without alphas or with all white alphas they'll bleed into your grass textures! If you don't need alphas in your detail textures just go into Photoshop and add a channel in the channels panel and make sure it's black. Turn on all of your channels including the alpha. Your texture should have a red tint to it but don't worry it wont look like that in Unity. Save it as a 32 bit alpha and make sure when you bring it into Unity it interprets it with an alpha. Replace the old texture with the new one in your detail mesh. Once all your detail meshes have alpha, edit one of your detail meshes or grass textures and it should update. Now the lines in the grass textures should be gone!

you could try settings your wrap mode in the texture to clamp... and just playing around with the import settings

It's mipmapping.

Either turn off mip-mapping on the grass material, or pull the UV's in about 8 pixels from the side of the map.

Remember, mip-mapping halves in size per level, and obviously, as you blur a texture more, artefacts from that will become more noticable :)

My solution to that problem:

In photoshop (or the software u use) make sure, that the painted object e.g., grass, is lifted a few pixels upwards from the bottom, also make sure that theres enough room to the other edges.

now export it to Unity.

ATTENTION: U wont see any change in the editor for now, cause u first have to close Unity and reopen it. Voila, the line above ur grass should be gone (at least it worked for me this way)

I've seen artifacts like this (just ran into one today) when the spacing in my Sprite map isn't large enough. If you are using SM2, you can set the distance between your sprites to 4 to see if that resolves it. If you're not using SM2, make sure you have a bit(4px) of trim on each side of your sprite before you import it.

Hey y’all. If anyone finds this in 2018 and onwards, I found a simple fix that just simply shrinks the UV box slightly.


Save this WavingGrass.shader file to your project to replace the default grass one.
http://pastebin.xyz/p?q=VDhWQkg


If that site fails you need to change line 35 in the built in WavingGrass.shader to

	fixed4 c = tex2D(_MainTex, (IN.uv_MainTex * 0.98) + float2(0.01,0)) * IN.color;