Weird problem importing Sketch Up files up to Unity

I've been using Google Sketch Up for a uni project thats due soon, I've modeled everything in Sketch Up but now I'm having a problem importing the Sketch Up files into Unity.

It's a weird problem, I've made one model in Sketch up which imports fine with no problems, however, when I try to import other models, I just can't see them, or I can see a single part of the model, like a single cylinder. It varies model to model, even though I'm keeping everything the same. I don't understand where the problems coming from since one model imports perfectly, although if I try to add to this model in Sketch Up and import it to Unity, it doesn't work any more and I cant see it. All of the object information is there, and I get the moving mechanism, just no visible object!

Has anyone else had this problem or does anyone know how to fix it?

I'd really appreciate the help


Strange things are known to happen when importing Sketchup files to Unity is due Sketchup's being based on different modelling technology than game engines are used to working with.

There are a couple workarounds people have used -

One way is this:

1) Download or create a .skp model in Sketchup

2) In Sketchup, export your model to "Google Earth 4 (*.kmz)

(note: be sure to choose version 4, because the other one is different)

3) Change the extention of the kmz file to .zip

4) Pull out the .dae file

  • for some reason this tends to work better than saving as a .dae right out of sketchup

Another way is to import the model to blender / other modelling software and doublecheck for no reversed polies / double geometry, then export as .fbx from there.

If neither of those work for you, you may have to dig deeper in the forums - this topic has been an issue for quite a while.

Someone else has had a problem with this before, and here is a mini tutorial I wrote to fix the "invisible faces" problem:

This is NOT a sketchup issue. I've tested this several times, when you create a new project importing the same FBX file, exported from SU, the geometry comes in just fine no missing walls. BUT if you re-import the same file just modified, geometry goes missing. My SU models do NOT have any normals facing the wrong way!

Only solution for now is to create a new project every time you make a change in the models geometry that needs to be re-imported.

I hope this issue can be solved by UNIY some time soon. Haven't had this issue with the version 2.6.

I'm happy to assist in any way I can.

I noticed sometimes that my models are in Unity, you just can't see them because they're extremely small. You might want to try fixing the scale factor. Click on the asset in the project menun, then in the Inspector window, look for "Scale factor" under "Meshes". Make sure it is at 1.0, rather than 0.01. Then at the bottom, click Apply. Suddenly your model is the right size! Hope that helps.


I know this thread is super old, but there is a solution to get SketchUp to Unity without weirdness.

Try exporting DAE, un-selecting triangulation in options. Import DAE to Blender. Select object, go into edit mode ‘A’ to select all, press ‘W’ select remove doubles. That will clean up your geometry. While still in edit mode hit ‘U’ to unwrap your geometry.

You’ll be all set for unity!