Weird problem on the normals of an imported model. please help!!

My question is regaurding the importing glitch i am having for the normals of my latest model. I am lost and I dont know what to do to fix it...

Here is a link to the forum post with screenshots of the problem. If you have an answer please leave it there.

http://forum.unity3d.com/viewtopic.php?p=332343#332343

Typically, issues with surface normals and Maya are solved by unlocking the normals, and then smoothing or unifying the normals. Failing that, one can export the mesh as an OBJ (without normals), and then re-import the mesh. Maya will then generate new normals.

It has nothing to do with unlocking normals or smooothing normals. even tried exporting obj with no normals... read the forum forum posts from the link i sent u. The unity team is working on it it also details everything I have tried and what information i have found out so far... Apparently the issue changes based on uv position.

I lucked out in that I have a custom shader for my specular contribution that relies on a Normal map. I was able to correct my artifacts with a fairly smooth normal map. I don't see anything specific in my shader except that the spec is driven by the normal map.

I'm sure you've tried this already, but just thought I'd let you in on my solution.

This has been fixed in Unity 3.0: it has better TangentSpace calculation and alternatively you can import TangetnSpace from fbx/mb/max.