Weird ring-shaped artifact on terrain around camera

For some reason, I see a ring-shaped artifact on my terrain. (The artifact is the white/gray path in the picture).

It moves around with the camera. If I move forward, the ring moves too. Also, its width varies when I go up and when I go down.

The problem doesn’t seem to be related to the terrain itself. I have three similar scenes, and the problem happens in all of them. I have even tried replacing the unity terrain with a simple plane, but the same thing happens.

The problem doesn’t seem to be in my GFX card either, I’ve tried it on two computers.

Also, I’ve done a test in ortographic mode. In ortographic mode, the glitch does not appear at all, until I am at a specific distance from the terrain. At that point exactly, the glitch covers the whole view. Nothing can be seen.

On an older version of my project the artifact doesn’t occur. Could something have gotten corrupted, or could I have changed some weird setting inadvertently?

Any insight will be highly appreciated!

I suspect it has something to do with mip-map levels on that grass texture. Depending on your texture import settings, the system will create several successive images and switch between them depending on the distance from the camera. It almost looks like one of the middle mip-map textures is messed up somehow. Just a guess.