Weird Shadow on my Model.

Hello There, I’m beginner using unity and 3ds max, I’ve created my model in 3ds and imported to unity but when I looked to it in unity viewport it has a weird shadow not like 3ds and udk viewports. I will add an image to see my problem and please someone help me and tell me whats wrong?

It looks like to me that the normals of the model are messed up, one fix you can do for this in Unity is to select the 3D model in the project folder and there should be a drop down box for normals, change this to calculate and see what happens there (you may need to change the smoothing angle slider a bit).

Dont use auto smooth or smooth for game…just use smooth edge…that’s enough for good game mesh…try it…give detail to model by texturing…

Fix : IN Unity select the model in the project Assets. And change these options in Inspector:

Check Swap UVs & Generate Lightmap

Change Normals to Calculate.

Adjust Smoothing Angel (Depend on the Model Shape)

Works For me and may not work for You. Thanks for Reading…