I’m looking for a better name than the lengthy “coordinate” to use when dealing with 2D arrays and the composite of the indices like so:
public class Map
{
public int x; // x coordinate
public int y; // y coordinate
byte[,] data;
public static Vector2 CoordinateToWorldPosition(IntVector2 mapCoordinate)
{
return Vector3.zero;
}
public static IntVector2 WorldPositionToCoordinate(Vector2 worldPosition)
{
return new IntVector2();
}
}
I basically only need this when returning both indices from a function at once, but that made me think that my naming is not yet perfect.