What is the best way to fix texture z-fighting?

My hardware specs are Mac G5 PowerPC Tower running OS 10.5.X and Unity 2.6. The graphics card is an ATI Radeon 9650 (256MB). Not a super setup, but what I have available at my school.

I am getting z-fighting -- I think -- in the Scene View with terrain and other meshes. This event also occurs with the Axis Gizmo in Scene View.

Any suggestions on how to prevent this from happening? Is the solution in Unity or OS?


Here are some example screenshots of the issue:

Screenshot 1 Screenshot 2 Screenshot 3

That's definitely not anything to do with z-fighting. That's the axis gizmo getting horribly messed up for some reason; I've never seen that happen before so I don't know the cause. It may be a driver problem.

Ouch! That's the exact same problem which I get on my computer, I haven't seen it on the scene view handle though, but it can happen for all meshes in my scene, so it's probably just a question of time before I get the problem with the scene view handle. I don't know about any solution though, it seams to be a hardware related problem since it doesn't happen on my other computer.

Hope someone else knows though.

Looks like some video driver issues I've seen in the past on my old Radeon x800 (not specific to Unity). Updating the drivers fixed the issue.

I started disabling the visibility toggle on GameObjects with a larger mesh such as water and it seemed to help quite a bit. We have some Intel Macs and we have no problem, so I think it is safe to say that it is a hardware specific issue.

Thank you for correcting me, it is not a Z-fighting issue.

your probleme is not z-fighting... but if it were, setting up the carmera clipping would help.