what is there diffence between = and += ?

in my code I had it as _moveDirection = jumpForce , straight from the scriping manual but I also so it wrote as _moveDirection += jumpForce , both appear to behave the same way is there a better way than the other of the 2 and if so could you briefly explain why.

_moveDirection += jumpForce;

Is exactly the same as:

_moveDirection = _moveDirection + jumpForce;