What is TLS Allocator ALLOC_TEMP_THREAD, underlying allocator ALLOC_TEMP_THREAD has unfreed allocations and how do I fix it.

So I was just minding my own business making a quick little game in Unity2D and then I got these error that I am unsure of how to fix or what they mean:

TLS Allocator ALLOC_TEMP_THREAD, underlying allocator ALLOC_TEMP_THREAD has unfreed allocations, size 28
Allocation of 28 bytes at 0000022F800000B0

I am assuming these are being caused by a memory leak but I am not sure and nothing in my code looks like it would cause a memory leak.

Here is the only script I have in my game right now:
using UnityEngine;

public class PlayerMovement : MonoBehaviour
protected float speed = 10.0f;
protected float jumpSpeed = 15.0f;
protected bool isGrounded = false;
public Rigidbody2D rb2;
void Update()
if (Input.GetKey(KeyCode.A) || Input.GetKey(KeyCode.LeftArrow))
rb2.AddForce(transform.right * -speed);
} else if (Input.GetKey(KeyCode.D) || Input.GetKey(KeyCode.RightArrow))
rb2.AddForce(transform.right * speed);
} else if (Input.GetKeyDown(KeyCode.Space) || Input.GetKeyDown(KeyCode.UpArrow))
if (isGrounded)
rb2.AddForce(transform.up * jumpSpeed);
void OnCollisionEnter2D(Collision2D col)
if (col.gameObject.tag == “Ground”)
isGrounded = true;
void OnCollisionExit2D(Collision2D col)
isGrounded = false;
(^ yeah i know it’s really messy don’t judge me)
So what in this script is causing this error

@ZenTheDev1 I was having this in Unity 2020.1. I removed the Allegorithmic substance support, including Editor modifications, and the errors went away.

Same error I’m using unity 2021.3.12f1 when will they fix it?,Same ERROR i’m using unity 2021.3.12f1 when will you they fix it .

This is one of those kind of errors where frankly console should realize it’s the Editor sh*dding the bed and stop making it everyone else’s problem. I am busy beta testing stuff and it clogs the console with useless errors.

I had the same issue after updating my project to a newer version. It was specifically happening after I would push my changes with the Collab tool. Turns out the issue was I didn’t add WebGL to the new version and had forgot I had done some testing early on with WebGL in the project and hadn’t removed everything pertaining to it. After adding the WebGL Module to the Unity version this issue was fixed.

Happens on 2020.3.28 as well after publishing an update to Collaborate. Restarting Unity shuts the message up, but it’s a lousy solution.

Also getting a similar error on 2020.3.4f1 and 2020.3.3 but only once after I build the game into WebGL. After building though, if I try to run the game in the editor, I get 999+ of the same errors.

I saw a post years ago about this same issue in Unity 5.3 or something, and they fixed the errors in the editor by reimporting all the assets in the project which works for me. But, Unity devs don’t want people doing this as it is time and resource intensive so I submitted a bug report for those reasons and because I think the errors are why the build won’t play on learn.unity.com. This is not surprising, but I can’t build the game without causing the errors again so I can’t publish the newest version of my game. :confused:

2021.1.0f1 here, started appearing after I deleted a lot of trees/grass from the terrain object.

Also, every little move in editor causes now huge repaint delays, so I assume the error aka mem leak is on terrain itself.

Looks like (ugly…) bug on Unity.

Oups after thinking, it appears after BUILDING and stays on unresolved - Editr repeats “Application.UpdateScene” hold on busy for 20 and more sec on every single click… aaaagh

This is usually an “internal” thing.

Sometimes it’s editor code going awry, sometime internally stacked objects in weird patterns caused this (shuriken days), Some packages can cause this such as collab 2.0 during sync

The general error seems to speak to potentially untracked memory allocation as you say.
Issues.unity is littered with issues adorned by this general nonspecific error.

Make regular backups and be ready to roll back seems to be the only real defense.

restart unity

I have the same error on Unity 2020.2.2f too
It always happen when I was build to iOS or Android

if I re import all asset the error will gone… just this time
But, if I open the project next time it will error again and I cannot re import all asset every time because my project is very big 10++ GB

I’m getting the same message from a memory leak in my scene after updating from Unity 2021.1.7 to unity 2021.2.7f1. In my case it seems like I can trigger the memory leak at will by 'play’ing the scene once, leaving play mode, and then clicking on any terrain piece. While I’m sure memory leaks can stem from many places, it makes me think mine might be stemming from the terrain tools package (Which I believe also updated in the background).

Has been happening for 3 years now for me after pushing a Collab update. It also triggers sometimes when using package manager to download assets from the asset store. Restarting Unity always fixes it, but I don’t understand how this issue hasn’t been fixed after so many years and numerous reports.

I’m in the same boat, this just started happening to me after I updated from 2021.3.10f1 to 2021.3.12f1.

Same idiot still in unity 2020.2.40f1 when I Toggle oN or Toggle Off