What is wrong with my smooth shading?

I have a model that I made in Blender. It has beveled edges so I set it to smooth so they would appear rounded. The problem comes in that the model gets very very dark near the bottom as seen in the picture. There should be enough light that this doesn’t happen, the ground isn’t that dark. I thought I could minimize it by flat shading the flat parts, but that just creates a horrible line where the smooth shaded parts are, as also seen in the picture.

The wall that the pedestal thingy is attached to was smooth shaded as well and had the same problem. Because it doesn’t have any vertical bevels those lines didn’t appear.

How can I get this model to be smooth around the bevels but not look so horribly dark? Is there a setting somewhere to make it less sensitive to light? Or maybe something else that I don’t know about?

Use an edge split modifier, don’t do a thing to the modifier INCLUDING APPLYING. That’s how I usually solve this. There’s a way to do it in unity but find that harder, and have less control since you can actually pick which edges are smooth or not with the modifier.