What is wrong with this Shader

I have a Shader and i’ve never used shader, so i don’t know what is wrong :frowning:

Shader "Reflective/Diffuse Transperant" {
Properties {
	_Color ("Main Color", Color) = (1,1,1,1)
	_ReflectColor ("Reflection Color", Color) = (1,1,1,0.5)
	_MainTex ("Base (RGB) Gloss (A)", 2D) = "white" {}
	_Cube ("Reflection Cubemap", Cube) = "_Skybox" { TexGen CubeReflect }
}
SubShader {
	LOD 300
	Tags {"Queue"="Transparent" "IgnoreProjector"="True" "RenderType"="Transparent"}

CGPROGRAM
#pragma surface surf Lambert alpha

sampler2D _MainTex;
samplerCUBE _Cube;

fixed4 _Color;
fixed4 _ReflectColor;

struct Input {
	float2 uv_MainTex;
	float3 worldRefl;
};

void surf (Input IN, inout SurfaceOutput o) {
	fixed4 tex = tex2D(_MainTex, IN.uv_MainTex);
	fixed4 c = tex * _Color;
	o.Albedo = c.rgb;
	
	fixed4 reflcol = texCUBE (_Cube, IN.worldRefl);
	reflcol *= tex.a;
	o.Emission = reflcol.rgb * _ReflectColor.rgb;
	o.Alpha = c.a;
}
ENDCG
}

FallBack "Reflective/VertexLit"
}

There is nothing wrong with the shader.
it is somethign your end.
Could be versio of Unity, but I dont think so.
Anyway, here is a package that has your shader code and a correctly done cubemap and shader attached to a prefab cube.
Once imported, you must add a texture to the material in the “Cube1” prefab. (due to 512 kb constraint on uploads my package exceeded the limit(Edit: I will upload the other image in a cmment below this answer, so you have what i have in front of me))
[24113-cubemapwithyourshader.zip|24113]Then drag the “Cube1” object to your scene or near the camera and have a look .
It works!!
Anyway. Hope that helps dude.
Gruffy