What issues can I run into with using an older version of unity?

I am currently using 2017.3.1f1 which is already a couple versions behind the latest and I am using Google firebase for auth and database. I have been running into all sorts of headaches with firebase not working properly. I found an excellent tutorial on Lynda that gave me a barebones template for exactly what I want to use firebase to do. The project files for the tutorial are in 5.6.1. When I run it in 2017.3 I get asked every time to remove obsolete files, but if I remove them then I get compiling errors about system.threading.tasks, which I googled and found that I need to change my api compatibility to 4.6 experimental, which I do and then I get more compiling errors…

My point is that I don’t think firebase is stable on 2017+ versions of Unity, and I know that it is working great on 5.6.1 since I downloaded that version and everything runs perfectly. My game isn’t exactly groundbreaking or overly complicated so I don’t think I need any cutting edge features of Unity or .Net, but I didn’t know if anyone can think of any major issues that I might run into if I stick with 5.6.1 to build my game. I’m relatively new to Unity and just getting started with my game and I don’t want to spend loads of time working on something only to realize that 5.6.1 isn’t going to work. It seems like there are people that are still working on even older versions than 5.6.1.

I apologize if there isn’t enough information to answer this question, I realize there are lots of things that can come into play. I guess the best thing for me to do would be to look through the list of changes for each version between 5.6.1 and the most current and see if there is anything that would be a deal-breaker.


Unity 5.6 works and will continue to work, that’s not a problem at all. Actually, game studios are rarely using the latest version of a public game engine like Unity, precisely for the kind of problems you are experimenting: plugins and external libraries don’t always follow the engine’s updates.

I would suggest you to find the version that suits your needs and use it (5.6.1 here it seems). If you don’t need the functionnalities brought by the latest versions you can use this version without any problem.