What setting did I change for this to happen,What did i do for this to happen?

I’m making a Chessgame following a youtube tutorial (“Chess Game Tutorial • 1/5 • [Tutorial][C#]”) and in the tutorial I draw a chess board with the help of lines, all normal, Chessboard getsdrawn everywhere except in the camera. This happens in every project/data i have and i have no clue on how to fix it, please help.

It looks like the Chess Board is just made of Debug.DrawLines. Is this correct?

Gizmos will only get drawn in the scene view (not in the game view) unless you tick Gizmos on the top of the game window (see below). Note that Gizmos will not be visible in your final build. I think the tutor will cover creating an actual chess board later in the tutorial series. For now just enable Gizmos in the game view and keep going! Good luck!