What Xcode can I use with a late-2006 MacbookPro?

Rather unwisely, I’ve updated my iPhone 4 to iOS 6.1, and now I can’t put builds of my Unity iOS app onto it using XCode 4.2. Unfortunately I cannot update to XCode 4.6 without being on Mountain Lion, and I can’t upgrade to Mountain Lion with anything earlier than a mid-2007 Macbook Pro! Apparently I can use Xcode 4.6 with Lion, but that is no longer available in the Mac App Store!

If I want to put builds of my app onto my phone for testing, am I basically a bit stymied? Or is there a workaround?

I don’t know if this will be an end to my woes, but I managed to purchase Lion by calling the Apple tech support line and saying I’m a paid member of the Developer Program.