When editing Terrain brush does not fall on cursor

I am starting a new scene and I noticed something while I was trying to make a river. Wherever my mouse is in the Scene View, the blue hue (area of change) will only stay in the far corner of the map. It is almost as if the program isn’t recognizing my mouse (or touchpad) outside of those coordinates. The weird thing, is that when I use the mouse to move around the world it seems to work. The problem is only when I try to adjust the terrain by using a brush. Tried re-opening the project and restarting my computer but to no avail the problem still persists.

Any ideas?

Also, if this means that I should probably re-install the program, is there a way I can keep my files that I have made so far?


I ended up reinstalling as Owen said and it worked perfectly! Just a heads up to anyone who comes across this question. :slight_smile:

I possibly found a fix.
Find your main terrain asset in assets folder and push it over the scene, it should duplicate in the same position as your old terrain. Now just delete the old terrain in Hierarchy and it should work well. At least worked for me.
I was lucky I found this before reinstalling Unity 5.